Kbase P118246: Many duplicates records in database caused by BI running out of space and sending SIGKILL (-9) signa
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  01/06/2009 |
|
Status: Verified
SYMPTOM(s):
Many duplicates records in database
Error 854 in database log file
** Insufficient disk space to extend the before-image file. (854)
Client sessions are hung up and later on abnormally terminated be sending them SIGKILL signal
One or more transactions are open
Database shuts down by itself
Indexes in tables involved in open transactions got corrupted
SYSTEM ERROR: Ixundo failed in ixgen due to finding a duplicate key in index number <number>, This index may be missing a key. (5021)
FACT(s) (Environment):
Progress 9.x
OpenEdge 10.x
All Supported Operating Systems
OpenEdge Category: Language (4GL/ABL)
CAUSE:
The BI file runs out of space and client session being terminated by kill -9 (SIGKILL)
FIX:
Restore the database from backup
or
Dump the good records via unique indexes, disable the unique indexes and delete all the records via non unique indexes, load the good records and rebuild indexes