Kbase P142420: Unable to restart database after power outage. Getting error Can't attach shared memory with segmen
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/28/2009 |
|
Status: Verified
SYMPTOM(s):
Unable to restart database after power outage. Getting error Can't attach shared memory with segment id <segment ID number> for <dbname>.
SYSTEM ERROR: Can't attach shared memory with segment_id <number> for <dbname>
Database server did not start and old .lk file still exists from prior to power outage.
There is no server for database <dbname>. (1423)
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge 10.1A
CHANGE:
Power outage caused server machine to reboot.
CAUSE:
The .lk file has several pieces of information to prevent multiple processes taking control of the database simultaneously.
One of the pieces of information is the primary shared memory segment ID that the database broker created when the database is served.
Since a machine outage occurred, the normal database code to remove the .lk file was unable to run.
The subsequent attempts to start the database identified an old .lk file with invalid information.
The message reported indicates that the process which attempted to connect to the database read the .lk file and then tried to attach to the shared memory segment listed in the file which is no longer possible since all shared memory segments were destroyed during the machine reboot.
FIX:
Remove the .lk file that was left behind due to the machine crash.
Truncate the database BI:
proutil <dbname> -C truncate bi
If no errors are encountered while truncating the BI file the database will be ready to start normally after the truncate BI completes, otherwise you will need to go to backup.