Kbase P131417: SQL-92 Server stops working after multiple attempts to connect using wrong userid and password
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  27/10/2009 |
|
Status: Verified
SYMPTOM(s):
SQL-92 Server stops working after multiple attempts to connect using wrong userid and password
Error 8839 is shown in the database log file
No SQL servers are available. Try again later. (8839)
No more connections are allowed after the broker fills up all slots for SQL Servers with failed connections
Promon shows that the connection attempt was successful and increases the current users of the server
FACT(s) (Environment):
OpenEdge 10.1B03 Service Pack
All Supported Operating Systems
CAUSE:
Bug# OE00168616
CAUSE:
JDBC and ODBC drivers fail to close the socket connection appropriately when an error is received
FIX:
Option #1
Upgrade to OpenEdge 10.1C02 or later. Since this is JDBC/ODBC driver bug, the upgrade must be done on the clients
Option #2
Restart the database to reset SQL-92 Servers