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Kbase P141381: Getting error 5810 when accessing WebSpeed application
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   13/02/2009
Status: Unverified

SYMPTOM(s):

Getting error 5810 when accessing WebSpeed application

Msngr: Failed to make connection to WTA. <p> Verify all port configuration for the specified service are correct </p> (5810)

Msngr: Failed to make connection to WTA. Verify all port configuration for the specified service are correct (5810): Error: -66, Agent Port: 3010

FACT(s) (Environment):

Firewall between messenger and the WebSpeed transaction server is restricted with all the WebSpeed broker, agents and NameServer ports
WebSpeed agents port range set to 3202 to 3502
Agents' port shown on the Progress Explorer are all on 3000 ranges
The WebSpeed broker log shows the following error:

Timeout while waiting for connection to Server Process <pid#>
Restarting the WebSpeed broker caused the agents to start on the correct port ranges specified for srvrMinPort and srvrMaxPort
Windows XP
WebSpeed 3.1E

CAUSE:

The reason for agent starting on the different ports than the range of ports specified for srvrMinPort and srvrMaxPort is unknown. The ports WebSpeed agents started are blocked on the firewall.

FIX:

Restart the WebSpeed broker and verify that the agents are started on the correct port range.