Consultor Eletrônico



Kbase P141283: NameServer is not responding when queried
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/02/2009
Status: Unverified

SYMPTOM(s):

NameServer is not responding when queried


When querying NS1 with nsman, the following message appears:

NS1 is not responding


AdminServer log is filled with errors such as:

[AdminServer] * Error - fail to get access to Promsgs file. (com.progress.common.util.PromsgsFile$PromsgsFileIOException: juPrmOpen: unable to open message file: c:\pro\progv9\promsgs.)


Exceptions log is filled with exceptions such as:

**** 4 ****

Exception at Wed Feb 11 14:14:18 CET 2009: com.progress.common.util.PromsgsFile$PromsgsFileIOException
Message (excp): juPrmOpen: unable to open message file: c:\pro\progv9\promsgs.
Stack Trace:
com.progress.common.util.PromsgsFile$PromsgsFileIOException: juPrmOpen: unable to open message file: c:\pro\progv9\promsgs.
at com.progress.common.util.PromsgsFile.juPrmOpen(Native Method)
at com.progress.common.util.PromsgsFile.openFile(PromsgsFile.java:159)
at com.progress.common.util.PromsgsFile.<init>(PromsgsFile.java:98)
at com.progress.common.log.LogSystem.<clinit>(LogSystem.java:17)
at com.progress.chimera.adminserver.AdminServer.<clinit>(AdminServer.java:63)


====== Start exception logging == "exceptions.log" opened == Wed Feb 11 14:28:01 CET 2009 ======


**** 5 ****

Exception at Wed Feb 11 14:28:02 CET 2009: com.progress.common.util.PromsgsFile$PromsgsFileIOException
Message (excp): juPrmOpen: unable to open message file: c:\pro\progv9\promsgs.
Stack Trace:
com.progress.common.util.PromsgsFile$PromsgsFileIOException: juPrmOpen: unable to open message file: c:\pro\progv9\promsgs.
at com.progress.common.util.PromsgsFile.juPrmOpen(Native Method)
at com.progress.common.util.PromsgsFile.openFile(PromsgsFile.java:159)
at com.progress.common.util.PromsgsFile.<init>(PromsgsFile.java:98)
at com.progress.common.log.LogSystem.<clinit>(LogSystem.java:17)
at com.progress.common.property.PropertyManager.<init>(PropertyManager.java:2136)
at com.progress.common.property.PropertyManager.<init>(PropertyManager.java:2123)
at com.progress.common.property.PropertyManager.<init>(PropertyManager.java:2117)
at com.progress.ubroker.util.ubProperties.<init>(ubProperties.java:338)
at com.progress.ubroker.broker.ubroker.main(ubroker.java:140)


FACT(s) (Environment):

Progress/ OpenEdge is installed on a local drive, but this local drive is also configured to be a network drive.

AdminServer is started automatically on system startup using the local system account

Starting the AdminServer manually from within proenv using an administrator accounts works fine

Windows
Progress 9.x
OpenEdge 10.x
OpenEdge Server Technology Category: AdminServer

CAUSE:

The local system administrator account does not have the required permissions to access the network drive. Despite the fact that it is really a local drive/ mounted locally it will be accessed via network access as it had been configured to be a network drive.


FIX:

Change the account that starts the AdminService to an administrator account