Consultor Eletrônico



Kbase P141030: Assigning value to new field after activating an index online, while a remote client session is conn
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   06/01/2011
Status: Verified

SYMPTOM(s):

Assigning value to new field after activating an index online while a remote client session is connected, which prevents the activation of the index, results in 1422 error.

Added field and index online using the new field for the index.

Run proutil <dbname> -C idxactivate

Running idxactivate gets message related to pre-existing remote session

Activating Index <indexname> at Database timestamp <timestamp>. (12811)

Connections with timestamps older than <dbtimestamp> exist. (13246)

Do you wish to continue waiting..... Type y to continue (y
). (13247)

Answered "n" to the (13247) message after starting a second remote client session.

Assigning a value to the new field using the new index after "n" is selected to the 13247 prompt results in error 1422

SYSTEM ERROR: Index in for recid could not be deleted. (1422)

Data Dictionary still shows the index as inactive

FACT(s) (Environment):

OpenEdge 10.1C02 Service Pack
All Supported Operating Systems

CAUSE:

The index manager was not written to handle in a special way the key adds/deletes for indexes that are in the "prepare to activate" mode.

CAUSE:

Bug# OE00180634

FIX:

Workaround:
Close any client sessions to the database before running idxactivate which will allow the index to be activated.