Kbase P140341: AppServer on Windows fails to start with errors 5513, 8113, 8117, 8100
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  13/08/2009 |
|
Status: Verified
SYMPTOM(s):
AppServer on Windows fails to start with errors 5513, 8113, 8117, 8100
<component_name> was unable to create log file <logfile_path>. (5513)
Message from server : Application Server was unable to create log file <logfile_path>/<appserver name>.server.log. (5513) (8113)
IOException reading message from server : java.io.EOFException: pipe to server broken (8117)
ERROR: cannot start server. (8100)
The same AppServer (broker and related initial agents) can start flawlessly during another startup sequence of the AdminServer.
When the errors occur, at least one initial agent of the failing AppServer can start without error and access the AppServer server log.
FACT(s) (Environment):
Can start and query the AdminServer and NameServer.
AppServers brokers raising the errors are configured to start more than 1 server instance at startup
Low level of physical memory
Memory is swapping
Multiple NameServers, AppServers, Databases started by the AdminServer
Progress 9.x
OpenEdge 10.x
Windows
CAUSE:
The system is under heavy load, causing a race condition on the AppServer server log
FIX:
One possible workaround for this problem might be to limit the number of initial server instances spawned by the AppServer broker. This can be done using the initialSrvrInstance in the ubroker.properties file. This property limits the number of concurrent AppServer agents spawned at broker startup.
You might also need to reduce the memory footprint of the java processes related to the AdminServer components.
However the sustainable solution might be to upgrade the system's hardware configuration in order to better handle heavy load.