Consultor Eletrônico



Kbase P119518: Unable to start a database via procontrol in 9.1D on Windows
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   2/10/2009
Status: Unverified

SYMPTOM(s):

Not able to start a specific database via ProControl.

Spawned process failed messages.

<function>:Unknown O/S error during <system call>, errno <error number>, fd <file descriptor>, len <bytes>, offset <bytes>, file <file-name>. (9451)

Previous message sent on behalf of user <user number>. (5512)

Corrupt block detected when reading from database. (4229)

<func-name>: Error occurred in area <num>, block number: <num>, extent<name>: . (10560)

Writing block <num> to log file. Please save and send the log file to Progress Software Corp. for investigation. (10561)

SYSTEM ERROR: Wrong dbkey in block. Found <dbkey>, should be <dbkey2> in area <num>. (1124)

Rebooted the file server where the database is located and was still not able to start the database via ProControl.

File system diagnostics detected hardware problems associated with the disk where the database resides.

FACT(s) (Environment):

Can successfully start other databases on this file server.
Windows
Progress 9.x

CAUSE:

Hardware problems caused corruption to one of the database extents.

FIX:

Address hardware problem.
Restore database backup and roll forward AI (After Imaging) files if enabled, to bring database back to a consistent state.