Kbase P89695: Database Server shutting down as a result of after-image extent switch failure.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/11/2008 |
|
Status: Verified
SYMPTOM(s):
Database Server shutting down as a result of after-image extent switch failure.
SYSTEM ERROR: Attempted to exceed maximum size on file <current variable ai extent>. (9452)
Can't extend ai extent <current variable ai extent> (3779)
Database Server shutting down as a result of after-image extent switch failure. (5350)
FACT(s) (Environment):
Only two maximum size variable extents
Large files enabled
Online probkup running
Not enough disk space to add new extents for ai and bi files
All Supported Operating Systems
Progress/OpenEdge Product Family
CAUSE:
The online probkup initially caused an ai switch to the second ai extent. While the probkup utilitiy was running, the second ai extent eventually filled the "maximum variable" size of the ai file. Although the first extent was empty the database manager would not switch to this EMPTY extent for an unknown reason.
FIX:
STEPS:
1.) Disable after-imaging
$ rfutil dbname -C aimage end
2.) Truncate the ai extents to recover disk space
$ rfutil dbname -C aimage truncate
Consider adding more than two ai extents to the database structure.
$ prostrct add dbname addai.st
3.) Truncate the bi file to assist the following exectution time of the probkup
$ proutil dbname -C truncate bi
4a) Take a probkup of the live database,
$ probkup dbname <device>\dbname00.bak
Then enable after-imaging:
$ rfutil dbname -C aimage begin
- OR -
4b) Mark the database as backed-up:
$ rfutil dbname -C mark backedup
enable after-imaging:
$ rfutil dbname -C aimage begin
Start the Live database and take an online probkup
$ probkup online dbname <device>\dbname00.bak
5.) Restore the probkup to the HotSpare database server and begin roll forward
$ prorest dbname <device>\dbname00.bak