Consultor Eletrônico



Kbase P139693: Architect fails to start with error "An error has occurred. See the log file"
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   1/16/2009
Status: Unverified

SYMPTOM(s):

Error occurs during the installation process of Architect.

"Command line option syntax error. Type Command /? for Help."

The installation can proceed.


The following files are missing after the installation:
- %DLC%\oeide\install.log
- %DLC%\oeide\architect\eclipse\.eclipseextension
- %DLC%\oeide\eclipse\links\openedge.link



Architect fails to start with error "An error has occurred. See the log file"

"An error has occurred . See the log file"
"C:\Documents and Settings\user\workspace\.metadata\.log"

Java stack trace taken from the eclipse .log file:

Stack Trace:
eclipse.buildId=I20080617-2000
java.version=1.5.0_11
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
Framework arguments: -showlocation
Command-line arguments: -os win32 -ws win32 -arch x86 -showlocation -clean

!ENTRY org.eclipse.equinox.app 0 0 <date> <time>
!MESSAGE Product com.openedge.pdt.core.product could not be found.

FACT(s) (Environment):

OpenEdge 10.2A
Windows

CAUSE:

These errors occur when you install Architect from a source that contains extended characters in the path name. For example, if you install from a server named "\\myserver\Téléchargements\OpenEdge 10.2A", you receive the error.

FIX:

As a workaround, install Architect 10.2A to a directory structure that does not include extended characters.