Consultor Eletrônico



Kbase P139004: Getting error 704 trying to connect to a remote database using 10.1C installation.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   22/12/2008
Status: Unverified

SYMPTOM(s):

Getting error 704 trying to connect to a remote database using 10.1C installation.

** There is no server active for database <database> on -H <hostname> -S <service name>. (704)

FACT(s) (Environment):

Remote database is version 9.
Version 9.1E client from same machine can connect to the same remote database on the same port without error.
Windows
OpenEdge 10.1C

CHANGE:

Recent uninstall of 10.1C failed.

CAUSE:

Some portion of the 10.1C installation is damaged.

FIX:

Re-Install 10.1C
Since uninstall has already failed, the quick way to allow a re-install is just to rename or remove registry keys using Regedit to modify the Windows registry entries:
(Rename or delete the following keys relevant to the version that is to be reinstalled)
HKEY_CURRENT_USER\SOFTWARE\PSC\<look for version to be re-installed>
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\<look in each subsection>\<look for version to be re-installed>


This will allow the reinstall process to proceed.
If some portion of the registry outside of these sections are truly damaged, this may not correct any large problems stemming from registry corruption.