Consultor Eletrônico



Kbase P138090: Progress Explorer sporadically losing connection to AdminServer.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   7/6/2009
Status: Verified

SYMPTOM(s):

Progress Explorer sporadically losing connection to AdminServer.

Progress Explorer sporadically getting errors that access is denied or password incorrect when connecting to the AdminServer.

AdminServer is reporting that it can not connect to the same machine the AdminServer is supposedly running on and reports error 8171.

[11/24/08 2:28:17 PM] [3] [AdminServer] SvcControlCmd.connectToService() failure: Unable to connect to the service process at rmi://myhostname:20931/testbroker(after 2 retries) (8171)

ssh to host machine where AdminServer is running will occassionally get password incorrect messages when trying to connect but will occassionally successfully login using the same exact password each time.

FACT(s) (Environment):

All Supported Operating Systems
Progress 9.x
OpenEdge 10.x

CAUSE:

Multiple machines with same IP address and hostnames within the same network environment caused problems with different machines responding to requests at different times.

FIX:

Hostnames and IP addresses should be unique within a network environment.