Kbase P137780: Utilities are unable to connect to the Progress AdminServer when using IPv6 addresses
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/07/2010 |
|
Status: Verified
SYMPTOM(s):
Utilities are unable to connect to the Progress AdminServer when using IPv6 addresses
Unable to connect to Progress AdminServer at (8287)
Unable to connect to Progress AdminServer at rmi:://<IPv6 addr>:20931/Chimera (8287)
RMI based command utilities do not successfully connect to the AdminServer.
Unable to find (8281)
FACT(s) (Environment):
Using IPv6 addresses on this machine.
Querying brokers using IPv6 address. Example: nsman -name NS1 -q -r <IPv6 address> -u username
Not using -ipver option when starting the AdminServer
OpenEdge 10.1C
CAUSE:
Some network topologies, especially where the Java system default values are ?-Djava.net.preferIPv4Stack=true? and ?-Djava.net.preferIPv6Addresses=false?, may cause the RMI-based OpenEdge command line utilities to fail. The failure occurs when attempting to resolve an IPv6 hostname/IP address causing the connection to the remote process to fail. Example: nsman ?name NS1 ?query ?host ::1
FIX:
This issue can be avoided by following these steps:
1. Edit the $DLC/properties/JavaTools.properties and locate the ?[Common]? section. Within this section, modify the ?jvmargs=-ms8m ?mx25m? property by appending ?-Djava.net.preferIPv4Stack=false -Djava.net.preferIPv6Addresses=true?. The completed property should appear as: ?jvmargs=-ms8m ?mx25m -Djava.net.preferIPv4Stack=false -Djava.net.preferIPv6Addresses=true?.
2. Start the AdminServer with the ipver switch set to ipv6. Example: proadsv ?start ?ipver ipv6
These changes will result in the RMI-based OpenEdge command line utilities being able to successfully resolve IPv6 hostnames/IP addresses.