Consultor Eletrônico



Kbase P137604: Fathom/OE Management will not restart with configuration backup file in place
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   21/11/2008
Status: Unverified

SYMPTOM(s):

Fathom/OE Management will not restart with configuration backup file in place

Errors in admserv.log file

Loading Fathom defaults file: /apps/fathom/config/fathomdefaults.xml (10177)


Failed to install plugin Fathom. (7433)

Fathom initialization failed. (9733)

Fathom not installed: Plugin asked not to be installed. (ADMMsg014) (7439)


Java exception recorded in ads0.exp

Exception at Thu Nov 20 06:30:54 EST 2008: java.lang.NullPointerException
Message (excp): null


Stack Trace:
java.lang.NullPointerException
at com.progress.isq.ipqos.Probe.loadPropertyFromNodeList(Probe.java:1688)
at com.progress.isq.ipqos.Probe.parseDefaults(Probe.java:1667)
at com.progress.isq.ipqos.Probe.loadProperties(Probe.java:1612)
at com.progress.isq.ipqos.Probe.init(Probe.java:327)

FACT(s) (Environment):

UNIX
Windows
Progress 9.x
Progress 9.1x
OpenEdge 10.x
OpenEdge Management 3.1x
Fathom Management 3.x

CAUSE:

User named the backup configuration file fathomdefaults.xml instead of fathom.xml. The fathomdefaults.xml, does not exist by default. It is used to store default values for Fathom/OE Management

FIX:

To fix this issue.
1) Stop the AdminServer
2) Make sure no fathom.od* files exist
2) Rename the fathomdefaults.xml to fathom.xml
3) Restart the AdminServer
The Fathom/OE Management should start and the console should now be available with all expected user defined jobs/monitors/reports/etc.