Consultor Eletrônico



Kbase P137586: Error (8336) when starting Progress Explorer after machine has been disconnected from the network
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   11/21/2008
Status: Unverified

SYMPTOM(s):

Error (8336) when starting Progress Explorer after machine has been disconnected from the network

Unable to connect to Admin Server. Ensure Admin Server is running. (8336)

FACT(s) (Environment):

Machine had been disconnected from the network after the AdminServer had started
If machine is connected to the network the error does not occur.
All Supported Operating Systems
Progress 9.x
OpenEdge 10.x

CAUSE:

This is expected behaviour. When the AdminServer is started it binds it RMI socket to a specific IP address. Should the machine be disconnected from the network it's IP address changes, therefor the RMI socket becomes unavailable which in turn prevents the Progress Explorer from connecting to the AdminServer.

FIX:

Either do not disconnect the machine from the network or install the loopback adapter and have the AdminServer bind itself to loopback.