Consultor Eletrônico



Kbase P136907: Memory-related error messages in AppServer and database logs
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   6/9/2009
Status: Verified

SYMPTOM(s):

Memory-related error messages in AppServer and database logs

"Error occurred while creating/connecting to automation server for: MMRDUtil.ProgRunner Not enough storage is available to process this command."

Unable to allocate memory for token array. (9104)

** stget: out of storage. (1450)

Unable to create thread for proshut, error = <errno>. (5402)

Unable to create thread for proshut, error = 8. (5402)

Errors appear intermittently.

Errors appear on a single AppServer agent.

Appserver agent logging the error message grows over time as seen in Windows Task Manager VM Size column.

Once errors appear, they continue to appear until the AppServer agent is trimmed.

FACT(s) (Environment):

Appserver connects to database using shared memory.
Application connects to and disconnects from the database extremely frequently.
Windows
Progress 9.x
OpenEdge 10.x

CAUSE:

Bug# OE00177177

CAUSE:

Memory leak in database connection causes application functions to run out of memory when extremely frequent connections are made to the database.

FIX:

Upgrade to OpenEdge 10.1C03 or later or 10.2A01 or later. To work around this bug if upgrading is not possible, look for opportunities to reuse connections in the application rather than disconnecting and reconnecting. This will also improve the performance of the application.