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Kbase P136830: OpenEdge Replication Server startup fails with error 11691
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   3/25/2009
Status: Verified

SYMPTOM(s):

OpenEdge Replication Server startup fails with error 11691

Unable to start Fathom Replication

(11691) The RCB for this database cannot be opened. Error -216 occurred.

FACT(s) (Environment):

The shutdown of the OpenEdge Replication Server has been performed
New instance of the OpenEdge Replication Server was started before the shutdown of the first instance took place
OpenEdge Replication 10.x

CAUSE:

Bug# OE00169416

CAUSE:

The error may occur due to the timing issue in the sequence of starting up the new instance of the Replication Server while shutting down the existing instance of the Replication Server has not been finished.

FIX:

How to fix the problem once it has occurred:

The bug corrupts the replication.recovery file contents. Therefore, to fix the problem Replication will need to be disabled, recovery files deleted, replication enabled, and then re-source the target database.
Workaround to avoid the issue:

When shutting down the Replication Server, always check in the database log file for the existence of the message:

The Fathom Replication Server is ending. (10505)

Once the running instance of the Replication Server has terminated, it can be restarted using:

$ dsrutil <DB> -C restart server

On Windows systems, the Replication Server will terminate when the user-session that started it logs-out. Please refer to Solution P130259, "How to restart the Fathom replication server under the Local System Account"