Kbase P136713: Report Builder report containing freeform area shows incorrect vertical alignment.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  04/11/2008 |
|
Status: Unverified
SYMPTOM(s):
Report Builder report containing freeform area shows incorrect vertical alignment.
Freeform area appears too high on page, overlapping the line above.
Problem appears in report definition window, print preview window, and the printed report.
Problem first appears when report is opened for editing on a system without a driver for the printer that was originally used.
Problem disappears when a printer is selected that exists on the current development system.
Problem is seen again when the edited program is deployed on a system with a printer that does not exist on the current development system, but did exist on the original development system.
FACT(s) (Environment):
Report was developed on Progress 9.1D with an HP LaserJet printer driver.
Report has been modified on Progress 9.1D with a Xerox WC4118 printer driver.
Report is deployed on OpenEdge 10.1B with an HP LaserJet printer driver.
Report that has been modified on Progress 9.1D with Xerox WC4118 printer driver runs correctly on OpenEdge 10.1B or 10.1C system with Xerox WC4118 printer driver.
Windows XP
Progress 9.1D
OpenEdge 10.1B
OpenEdge 10.1C
CAUSE:
Same printer driver must be available on both development and deployment systems for reports to appear the same on both systems.
FIX:
Obtain a common printer driver that can be used at both sites. A physical printer does not have to exist at both sites as long as the driver is installed. Alternatively, print to a file or to a "soft" driver such as Microsoft Document Image Writer or a third-party PDF writer.