Consultor Eletrônico



Kbase P136209: EasyAsk server gets out of memory error
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   20/10/2008
Status: Unverified

SYMPTOM(s):

EasyAsk server not servicing searches gets out of memory error

EasyAsk server gets out of memory error

FACT(s) (Environment):

EasyAsk

CAUSE:

A typical EasyAsk environment has a staging server in which indexes are built. Dictionaries and indexes are deployed to all production servers using the Dictionary Deployer utility. If a dictionary has been identified in EasyAsk.properties as AutoReload, then when the production server detects a new dictionary, it will be loaded onto the server. An index will only be reloaded after a search is issued against an index and a new index has been detected on the server. The reload process loads the new index and deletes the old index. If a server has been established as a dedicated backup server and dictionaries and indexes are being deployed to it, but no searches are being issued to it then the index files will accumulate on the server and an out of memory condition may occur.

FIX:

If a server is going to have dictionaries and indexes deployed to it, then that dictionary should be set up to AutoReload and at least one search should be issued to the server after a new index is deployed. This will allow the server to have the current dictionary and index and it will be ready to be added or to replace a server in the production environment as needed.