Kbase P135586: Attempting to connect a DB via an application returns Webdev error "Impossible to connect to ". Nati
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  1/30/2009 |
|
Status: Unverified
SYMPTOM(s):
Attempting to connect a DB via an application returns Webdev error "Impossible to connect to <IP>". Native Progress access error (error 22)
Error number = <-1>
[MERANT][ODBC PROGRESS driver]Insufficient information to connect to the Data Source. SQL State = HY000 Native Error Code = 0
FACT(s) (Environment):
Progress 9.1D
Red Hat Linux Server
Windows XP client
CAUSE:
There is a problem with the connection configuration data. Check the ODBC data source manager
FIX:
Add the required Database to the System DSN of the ODBC Data Source Add a Data Source entry in the User DSN area Go into WebDev and specify the User DSN entry that was created for the applicationIn Linux DSN ODBC Data Source, there is a password property. Add this as a string key in Regedit (ODBC.INI)Reboot your machine