Consultor Eletrônico



Kbase P131789: Some AppServers fail to autostart after a system reboot.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   24/03/2009
Status: Verified

SYMPTOM(s):

Some AppServers will not autostart after a machine is rebooted.

Manually starting the AppServers also fail for the same group of AppServers that failed to start when configured to autostart.


The broker.log file for the failed AppServers show the following errors when the logging level has been set to 4:

IOException reading message from server : java.io.EOFException: pipe to server broken (8117)

ERROR: cannot start server. (8100)

Ending serverPool thread: S-0005. (8077)

admin error response received: 2. (8067)

<AppServer Name> port #### closed. (8065)

The AppServers that failed will auto start after removing the srvrStartupProc=<procedure name> line from the ubroker.properties file (or removing the reference to the Agent startup procedure in Progress Explorer) and rebooting the PC.

Subsequent attempts to start AppServers manually succeed, whether the AppServers were configured to autostart or not.

FACT(s) (Environment):

Windows 32 Intel
OpenEdge 10.1B

CAUSE:

The exact cause is unknown at the time of this writing.

FIX:

Remove or comment out the srvrStartupProc=<procedure name> line from the ubroker.properties file and examine that procedure to determine if it is running to completion or generating any errors.