Consultor Eletrônico



Kbase P126325: After installing SQL Client, the ODBC driver is missing from Windows ODBC Administrator list
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   24/03/2009
Status: Verified

SYMPTOM(s):

The Progress ODBC driver is missing.

After installing the SQL Client product, the ODBC driver is missing from the Windows ODBC Data Source Administrator Drivers list.

FACT(s) (Environment):

The option to perform a "Complete" install was chosen during the installation setup.
The SQL Client product was installed using the local Administrator account.
Windows
OpenEdge 10.x

CAUSE:

The [HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers] key in the Windows registry file contains invalid lines. These lines consisted of only the "@=" characters.

FIX:

Remove the invalid lines from that key in the registry.

Start-> Run -> regedit (run the Windows registry editing tool)
Right click the "My Computer" root key to highlight and choose Export.
Enter a file name. This file will be a copy of the entire registry (it is best to have a backup of the entire registry before modifying anything).
Expand the tree until you can see the [HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers] key.
Right click the [HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers] key and choose Export.
Enter in a new filename (e.g. odbc_drivers.reg).
Make a backup copy of odbc_drivers.reg in case the original needs to be restored to the registry.
Open that odbc_drivers.reg file in an editor of your choice.
Remove any lines that consist of only the characters "@=".
Save that odbc_drivers.reg file.
Right click the ODBC Drivers key and choose Delete.
At the Registry Editor's top line menu bar, choose File-> Import
Enter odbc_drivers.reg as the file name.
Exit the Registry Editor.