Consultor Eletrônico



Kbase P125560: ODBC client getting error: Access denied (Authorization failure) (7512)
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   3/24/2009
Status: Verified

SYMPTOM(s):

An ODBC client generates an access/authorization error when trying to query the database.

Access denied (Authorization failed) (7512)

Output from a select * from sysprogress.sysdbauth; query shows:
GRANTESS DBA_ACC RES_ACC
-----------------------------------------------
root y y
SYSPROGRESS y y
UX 64 bit Itanium with 10.1B03

FACT(s) (Environment):

MS Excel can access the database without getting the (7512) error.
A select "_user-name" from pub."_user"; does not return any records.
HP-UX
Progress 9.x

CHANGE:

This error started occurring after a dump and load of the database.

CAUSE:

The pre-dump version of the database was created by a non-root user. The database that had data reloaded into it was created by the root user. As a result, the non-root user no longer has DBA rights or privileges in the database.

FIX:

Use SQL explorer to modify the DBA permissions for the non-root user:

sqlexp <dbname> -S < service name> -user root
SQLExplorer> grant DBA to <the non-root user>;
SQLExplorer> commit;
SQLExplorer> quit;
sqlexp <sbname> -S <service name> -user <the non-root user>
SQLExplorer> revoke dba from root;
SQLExplorer> commit;
SQLExplorer> quit;