Kbase P119950: Appserver process remains in stopping status indefinitely
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/12/2008 |
|
Status: Verified
SYMPTOM(s):
AppServer process hangs and can not be shutdown
AppServer process remains in stopping status indefinitely
AppServer process fails to respond to management requests
FACT(s) (Environment):
Progress 9.x
OpenEdge 10.x
OpenEdge Server Technology Category: AppServer
CAUSE:
Client sends a large request to the AppServer agent , if the request is interrupted (like by a network error between the client and broker)
then the internal state of the agent is not properly cleaned up, once the agent is in this state it fails to respond and has to be manually killed with the OS tools.
CAUSE:
Bug# OE00131571
FIX:
Upgrade to 10.1B.