Consultor Eletrônico



Kbase P135584: EasyAsk ecommerce clicks are not returning results in default sort order
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   9/30/2008
Status: Unverified

SYMPTOM(s):

Why are my category and attribute clicks not returning results in correct default sort order?

FACT(s) (Environment):

EasyAsk Versions

CAUSE:

On the DataWorkshop/Tools/Index Builder/General tab there is a checkbox labelled Data Sorted in Default Order by Data Query.
If this box is checked, there should only be one Data Query and it must sort the data by the same columns as the Default Sort Order. Checking this box tells EasyAsk not to sort the results before returning them. This is an old technique and it is not suggested that it be used. However, it may be needed for very large products set (millions of products).
If this box is checked, and the Data Query does not order the data properly, clicking on categories or attributes will return data in the wrong sort order.

FIX:

Uncheck the checkbox labelled Data Sorted in Default Order by Data Query on the DataWorkshop/Tools/Index Builder/General tab. Rebuild the index and reload the index on the server. EasyAsk will sort all results by the Default sort order (unless specifically given a different sort order) before returning a result set.