Consultor Eletrônico



Kbase P135370: Client-Server connections Cannot see schema changes applied via JDBC
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   4/14/2009
Status: Unverified

SYMPTOM(s):

Existing Client-Server connection fails to read table with errors 450 3191

Cannot see schema changes added on-line

adding new objects on-line via OpenEdge Architect's DB Navigator

SYSTEM ERROR: Cannot read field from record, not enough fields. (450)

SYSTEM ERROR: Failed to extract field <field-num> from <file-name> record (table <table-num>) with recid <RECID>. (3191)

Couldn't extract field '<field>' from source in a BUFFER-COPY statement. (5367)

a new self-service client session finds the newly added objects

a new client-server client session fails to find newly added objects with errors 450 3191

FACT(s) (Environment):

OpenEdge 10.1x
All Supported Operating Systems
OpenEdge Database Category: Maintenance

CAUSE:

Bug# OE00175246

CAUSE:

Starting in OpenEdge 10.1A, Progress relaxed the requirement for exclusive access to a database by allowing for the addition of sequences, 4GL tables and any fields, indexes, and database triggers associated with a new table as long as they are added in the same transaction as the table. The behavior is somewhat expected. Please refer to Progress Solution P126802, "Cannot see schema changes applied online".

This issue is specific to existing Client-Server connections that held a lock from the remote server on the database table while changing the schema online.

FIX:

Workarounds:

Option 1a: Shut-down the database or
Option 1b: Request all Client-Server sessions to disconnect, then stop the spawned remote servers with:
promon > R&D > 4. Administrative Functions > 7. Terminate a Server
Then send an alert for re-connection.

Option 2: Request all Client-Server sessions to re-connect self-service.

For further information please refer to Solution: P39432, "How to trim ABL and SQL remote server processes"