Kbase P135172: Error "Snap-in failed to initialize. Name: Progress Explorer 10.1C" is generated when starting Prog
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/07/2010 |
|
Status: Verified
SYMPTOM(s):
Snap in failed to initialize errors when attempting to start Progress Explorer 10.1C after new installation of OpenEdge.
Snap-in error occurs when starting Progress Explorer
Snap-in failed to initialize.
Name: Progress Explorer 10.1C
CLSID:{15158793-7B40-46B7-B67B-FB403F8D4590}
Environment.log file may show two errors regarding <Value may be too long>. ret = 31 for InprocServer32 (Default)
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{15158793-7B40-46B7-B67B-FB403F8D4590}\InprocServer32]
(REG_EXPAND_SZ) "(Default)" = <Value may be too long>, ret = 31
(REG_SZ) "ThreadingModel" = "Both"
(REG_SZ) "JavaClass" = "com.progress.vj.explorer.ProgressExplorer"
(REG_SZ) "CodeBase" = "file://C:\Progress\OpenEdge\java\progress.jar"
[HKEY_CLASSES_ROOT\CLSID\{15158793-7B40-46B7-B67B-FB403F8D4590}\InprocServer32]
(REG_EXPAND_SZ) "(Default)" = <Value may be too long>, ret = 31
(REG_SZ) "ThreadingModel" = "Both"
(REG_SZ) "JavaClass" = "com.progress.vj.explorer.ProgressExplorer"
(REG_SZ) "CodeBase" = "file://C:\Progress\OpenEdge\java\progress.jar"
FACT(s) (Environment):
OpenEdge 10.1C
Windows
CAUSE:
Java is not properly installed.
FIX:
Reinstall Java:
1. Make sure all OpenEdge processes including the AdminServer, are not running.
2. Rename msjava.dll, jview.exe and wjview.exe (if you have any of these files on your system) in the Windows System32 directory.
3. Execute %DLC%\bin\3party\msjavx86.exe
***If you have a service pack installed, you may need to reinstall the service pack (if problem persists).