Kbase P135054: GUI clients connecting to the database via AppServer connections are receiving 748 and 1154 errors.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  9/10/2008 |
|
Status: Unverified
SYMPTOM(s):
GUI clients connecting to the database via AppServer connections are receiving 748 and 1154 errors.
The server or the system has no more resources. Please contact Progress Technical Support. (748)
No servers are available. Try again later. (1154)
ps -elf | grep _sqlsrv2 | wc -l (counts lines in the result set) show that the bulk of server slots for the database are being used by _sqlsrv2 processes
FACT(s) (Environment):
Startup parameters are adequate for the number of 4GL clients connecting to the database.
Database started via dbman command.
GUI clients connecting to database in a client server fashion via the Application Server.
promon -> R&D -> Status -> Servers show all servers slots are in use.
promon -> R&D -> Status -> Servers indicates some servers do not have users connected even though 4GL gui clients are receiving 1154 error messages.
IBM AIX
OpenEdge 10.1B02 Service Pack
OpenEdge 10.1B
CHANGE:
Started making use of 3rd party ODBC applications to view data within the database.
CAUSE:
ODBC clients were being spawned which resulted in multiple _sqlsrv2 processes being started against the database. These _sqlsrv2 processes limited the amount of server slots that were available for the 4GL clients connecting to the database.
FIX:
Modify the $DLC/properties/conmgr.properties file to initiate 2 brokers. One broker dedicated to 4GL clients and a secondary one dedicated to SQL92 clients. Shutdown and restart Database Broker so changes to the conmgr.properties file are utilized.