Kbase P134933: Client connects to local AppServer instead of remote AppServer when specifying the remote hostname o
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  09/10/2008 |
|
Status: Unverified
SYMPTOM(s):
Client connects to local AppServer instead of remote AppServer when specifying the remote hostname or IP address.
Client is incorrectly trying to connect to an AppServer on localhost 127.0.0.1.
FACT(s) (Environment):
AppServers and NameServer are on the same remote machine.
Client connects to the AppServer via the NameServer.
All Supported Operating Systems
Progress/OpenEdge Versions
WebSpeed Versions
CAUSE:
The hosts file on the remote machine is incorrect and has the hostname on the same line as localhost.
When the AppServer broker starts, it registers it's IP address with the NameServer. It is registering 127.0.0.1 because that is what is contained within the hosts file.
When the client tries to connect to an AppServer, it first connects to the NameServer and asks it for the appropriate AppServer's host IP and port number. The NameServer then passes the IP address (127.0.0.1) and port number of the AppServer back to the client and the client then tries to connect to the AppServer using those details.
FIX:
The hosts file should have at least two lines. First is 127.0.0.1 with "localhost" as the hostname, the second is the IP address of the machine with it's specific hostname.
E.g:
127.0.0.1 localhost
192.168.0.58 mymachine
The hosts file can be found in different locations depending on the operating system:
Unix/Linux: /etc/hosts
Windows XP: c:\windows\system32\drivers\etc\hosts
Windows 2000/2003/NT: c:\winnt\system32\drivers\etc\hosts