Consultor Eletrônico



Kbase P134375: Progress Explorer reports error 8336 connect to AdminServer on Unix machine which has two network ca
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   23/12/2009
Status: Verified

SYMPTOM(s):

Progress Explorer reports error 8336 connect to AdminServer on Unix machine which has two network cards with different IP subnets for each card.

Unable to connect to Admin Server. Ensure Admin Server is running. (8336)

The admserv.log file shows the AdminServer has bound to one specific IP address (not localhost) as expected.

FACT(s) (Environment):

AdminServer machine has multiple NIC cards.
Some machines within the site connect correctly to Progress Explorer.
Machines which connect correctly to Progress Explorer have entries in the operating system routing table to define a path to the machines on the subnet the Server's NIC card is bound to.
Machines which can not connect correctly to Progress Explorer have no entries in the operating system routing table to define a path to the machines on the subnet the Server's NIC card is bound to.
Progress/OpenEdge Versions
All Supported Operating Systems

CAUSE:

This is a network configuration problem on the client machines.

The routing table defined on the client machines do not have necessary entries in the OS routing table to properly route IP requests to the correct subnet.

FIX:

Modify the operating system routing table to define a direct route to the server's IP or to the subnet of the network the server's IP address is part of.

Refer to the OS documentation for the "route" command.