Consultor Eletrônico



Kbase P133937: Remote client fails to connect to a database via a mapped drive with error: building the database li
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   8/4/2008
Status: Unverified

SYMPTOM(s):

Remote client fails to connect to a database via a mapped drive with error: building the database list caused an unrecoverable error.

Progress 9.1D was running on this Windows 2003 SP2 box.

Progress 9.1D clients used a shared network install, not NetSetup.

Progress 9.1D was installed by an OS copy of all Progress files and the registry from another windows box.

FACT(s) (Environment):

Progress 9.1D was removed.
The remote XP SP2, 10.1B03 clients attempt a connection to two databases and receive the unrecoverable error message.
Local remote connections to the same two databases works fine using the local drive.
Progress 10.1B03 was installed correctly on the windows 2003 box and into the same directory where 9.1D was previously located.
Windows 2003
Windows XP
Progress 9.x
OpenEdge 10.x

CHANGE:

Upgraded from 9.1D to 10.1B03.

CAUSE:

In the removal of 9.1D, they failed to remove many of the registry keys they had copied over during the install.

FIX:

Completely remove 9.1D from the registry.