Kbase P133882: The OpenEdge 10.1C installation on Windows 2003 returns an error when registering the prox.dll libra
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  16/02/2009 |
|
Status: Verified
SYMPTOM(s):
The OpenEdge 10.1C installation on Windows 2003 returns an error when registering the prox.dll library
Unsuccessful File Registration
The following file(s) failed to self-register:
C:\Program Files\Common Files\Progress Software\10\prox.dll;C:\Program Files\Common files\Progress Software\PSCCab.dll;
FACT(s) (Environment):
Choosing OK on this message will return to the InstallShield and the install continues and completes
Starting any OpenEdge tool, for example launching prowin32.exe, will return the following error:
This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.
Reinstalling does not fix the problem
Manually registering prox.dll returns the following error:
LoadLibrary("C:\Progress\OpenEdge\101c\bin\prox.dll") failed.
GetLastError returns 0x000036b1
Service Pack 2 is not installed on the Windows 2003 machine
OpenEdge 10.1C
Windows 2003
CAUSE:
There is a bug in the Windows Installer that comes with Windows 2003.
CAUSE:
Release Note# OE00165220
FIX:
To resolve this issue please install Service Pack 2 on the Windows 2003 machine.