Kbase P133733: Error "Snap-in failed to initialize. Name:<unknown>" is generated when starting Progress Explorer
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  9/15/2008 |
|
Status: Verified
SYMPTOM(s):
Progress Explorer
Snap-in error occurs when starting Progress Explorer
Snap-in failed to initialize.
Name:<unknown>
CLSID:{15158793-7B40-46B7-B67B-FB403F8D4590}
FACT(s) (Environment):
OpenEdge 10.1B
OpenEdge 10.1C
Windows
CAUSE:
Entries for the Progress Explorer snap-in are missing from the Windows Registry
FIX:
WARNING - backup the Registry before making any changes:
1) Create an empty text file and rename it to ProgExp.reg
2) Copy the registry entries from the Note appropriate to the version of OpenEdge 10 installed (10.1B or 10.1C)
3a) Modify the 2 path entries for "CodeBase" (which should point to <DLC>\\java\\progress.jar)
3b) The path entries pointing to msjava.dll may also need to be changed
4) Save the file
5) Double-click on the .Reg file to add the entries to the Windows Registry