Kbase P133438: Local AdminServer becomes unresponsive when used with OpenEdge Managent
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  21/07/2010 |
|
Status: Verified
SYMPTOM(s):
Local AdminServer becomes unresponsive when used with OpenEdge Management
proadsv -q does not respond
Java core file shows Out of memory errors.
FACT(s) (Environment):
OE Management monitors 24 highly active DB's
:/diagnostics/system.jsp">http://<OE Mgmnt host name>:<OE Mgmnt port>/diagnostics/system.jsp shows Java Memory heap saturation.
OpenEdge 10.1B01 64-bit Service Pack
IBM AIX POWER 5.3 64-bit
OpenEdge Management 3.1B 64-bit
OpenEdge Management 3.1B01 64-bit Service Pack
CAUSE:
Running out of memory for java processes
FIX:
Increase the Java memory heap for the AdminServer.
To do this open the $DLC/properties/AdminServerPlugins.properties file.
At the entry [PluginPolicy.Progress.AdminServer]
Change the or add the parameter -Xmx for jvmargs, with the value you need.
For example, to have a maximum of 1024 MB you would have:
jvmargs=-Xmx1024m
Depending on what OpenEdge is monitoring and the amount of information is collecting from the resources the value of 1024 MB may be too high or at some point low.
Monitoring during peak time of the Java Memory heap with the OE management can be done using the diagnostic tool:
http://<OE MGMNT host name>:<OE Mgmnt port>/diagnostics/system.jsp
Example:
:/diagnostics/system.jsp">http://localhost:9090/diagnostics/system.jsp
It should show if the current value is enough.
Please refer to Solution P99089, "How to increase or modify java heap size for the Admin Server in OpenEdge ?"