Consultor Eletrônico



Kbase 18251: Error 4110 when printing to LPT2, LPT3
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   3/25/2009
Status: Verified

SYMPTOM(s):

Unable to create Printer Device Context: . (4110)

Error 4110 when printing to LPT2

Error 4110 when printing to LPT3

FACT(s) (Environment):

Windows
Progress 9.x
OpenEdge 10.x

CAUSE:

It is not possible for the Progress version to create a printer from the LPT2 (or LPT3) given.

For the OUTPUT TO LPT2 to work, a printer must be connected to it.

A "normal" network printer that is captured to the port is NOT a correctly connected printer if you want to use Progress. The Progress session accesses the registry to find information on what LPT2 corresponds to from the installed printer devices.

FIX:

To make sure that the network printer is correctly installed follow
Follow these steps:

1) Check the registry entry:

HKEY_CURRENT_USER\Software\Microsoft\windows NT\CurrentVersion\Devices
This entry must include the following:

Name: PRINTERNAME or UNC NAME
Data: "winspool,LPT2"
If the LPTx used in the OUTPUT line is not in this key then the LPTx is not installed with a printer connected.

2) To correctly install a network printer, first install a local printer using "Add Printer". Select which port (in this case LPT2) this printer should be connected to and install the correct driver (and version) for the network printer. The driver must be setup to use correct format and the raw datatype.

3) Install the network printer and again configure this to have the same settings as the newly installed local printer.

4) Search the registry again to see if the LPT2 has indeed been configured and then rerun the program.