Kbase P126162: Admin Server won't start after adding additional Progress products
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  19/11/2010 |
|
Status: Verified
SYMPTOM(s):
Admin Server won't start after adding additional Progress products
Java stack trace found in admserv.log file
Stack Trace:
java.lang.NoClassDefFoundError: Lcom/sonicsw/mf/framework/container/ContainerImpl;
at java.lang.Class.getDeclaredFields0(Native Method)
at java.lang.Class.privateGetDeclaredFields(Class.java:1522)
at java.lang.Class.getDeclaredField(Class.java:1214)
at java.io.ObjectStreamClass.getDeclaredSUID(ObjectStreamClass.java:1474)
at java.io.ObjectStreamClass.access$400(ObjectStreamClass.java:47)
at java.io.ObjectStreamClass$3.run(ObjectStreamClass.java:335)
at java.security.AccessController.doPrivileged(Native Method)
at java.io.ObjectStreamClass.<init>(ObjectStreamClass.java:333)
at java.io.ObjectStreamClass.lookup(ObjectStreamClass.java:253)
at java.io.ObjectStreamClass.<init>(ObjectStreamClass.java:329)
at java.io.ObjectStreamClass.lookup(ObjectStreamClass.java:253)
at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1010)
at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:278)
at sun.rmi.registry.RegistryImpl_Stub.rebind(Unknown Source)
at com.progress.common.rmiregistry.PrimaryRegistryManager$PrimaryBinder.call(PrimaryRegistryManager.java:224)
at com.progress.common.rmiregistry.TryIt.run(TryIt.java:186)
FACT(s) (Environment):
Windows
OpenEdge 10.1B
CAUSE:
A service pack was installed prior to adding addition Progress products or components. Once the additional products or components were added the Adminserver would not start because the original service pack was not reapplied.
FIX:
Re-apply the service pack to bring all installed components to the same level.