Kbase P133032: Error 748 occurs when connecting to a database in client server mode
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/07/2010 |
|
Status: Verified
SYMPTOM(s):
Error 748 occurs when connecting to a database in client server mode
The server or the system has no more resources. Please contact Progress Technical Support. (748)
Database services both remote and local clients.
Remote clients cannot connect to the database.
Remote JDBC clients cannot connect to the database.
Remote 4GL clients cannot connect to the database.
Not using multiple brokers for the database.
FACT(s) (Environment):
Local clients can connect to the database.
All Supported Operating Systems
Progress 9.1D
Progress 9.1E
OpenEdge 10.x
CAUSE:
Database was started with a -n which is not sufficient for the number of client and server processes connecting to the database.
FIX:
1. Configure the database broker to have multiple login brokers (1 for 4GL clients and 1 for SQL clients).
2. Ensure that the database startup parameters are configured to address the remote server processes as well as the number of clients connecting to them.
3. If making use of a firewall, ensure that the database brokers are each started with a different -minport and -maxport range for each of the login brokers being start.
Detailed instructions for configuring multiple brokers can be found in solution P7843, "How to configure a secondary SQL-92 Broker for Progress 9.1D and above"