Kbase P130631: Progress Explorer fails to connect to the AdminServer on guest VMCentos5 with error 8336.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/07/2008 |
|
Status: Unverified
SYMPTOM(s):
Progress Explorer fails connection to guest Virtual Machine running Centos5
Unable to connect to Admin Server. Ensure Admin Server is running. (8336)
FACT(s) (Environment):
Linux Centos5 is not a certified version of Linux.
Host machine is Windows XP sp2.
Windows XP
Linux Intel
CAUSE:
Configuration is not correct.
FIX:
Steps needed to make a successful connection:
1. Make sure of connection to LAN.
2. Run a proenv session on guest Virtual Machine: $DLC/proenv
3. Run sudo /sbin/ifdown eth0
4. Run sudo /sbin/ifup
5. Run sudo /sbin/ifconfig | more
6. In the host file on the UNix box, /etc/hosts, enter the hostname of the guest VM Centos5 box with ip from ifconfig reading for eth0 on a separate line from the localhost line. Also entered the IP address and hostname of the windows box.
7. In the hosts file, C:\WINDOWS\system32\drivers\etc\hosts, on the windows box enter the host name of the VM Centos5 guest with its eth0 IP address.
8. Ping from host to guest and back..
9. Still in the proenv environment, su to root on the Centos 5 guest.
10. Change the NS1 NameServer autostart to 0 in the $DLC\ubroker.properties file.
11. Run proadsv -start
12. Run proadsv -q to verify it's alive.
13. Telnet <Centos5 hostname> 20931 to check AdminServer port is listening.
14. Start Progress Explorer and connect using the default port, 20931 with the UNIX account and password provided which has sudo root permissions.