Consultor Eletrônico



Kbase P132815: Progress client connecting to Oracle DataServer crashes randomly
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   30/06/2008
Status: Unverified

SYMPTOM(s):

Using Oracle 10G R2 version 10.2.0.1.0

ABL client terminates intermittently with memory violations

Client sessions are seen to terminate with no error in the DataServer log file

No errors are seen in the client session - session just dies

No errors are reported in the DataServer log file

DataServer connection to the Oracle database is made via SQL*Net

Client are running within a Citrix session

Progress client generates several "types" of protrace files

Protrace from PROWIN32 reads:

sslslini

Protrace from PROWIN32 reads:

lnxnucoptg

Protrace from PROWIN32 reads:

skpinunregoobhdlr
nioqwa
upicui2
upirtrc

Protrace from PROWIN32 reads:

skpinunregoobhdlr
skpinunregoobhdlr
ttcfour
ttcdrv

Protrace from PROWIN32 reads:

ztvull
skpinunregoobhdlr
nioqwa
upicui2

Protraces refer to Oracle Client .DLLs, such as oracore10.dll and oran10.dll

FACT(s) (Environment):

OpenEdge 10.x
Windows

CAUSE:

The client crashes disappeared after upgrading from Oracle 10.2.0.1.0 to Oracle 10.2.0.4.0. This, the fact that many protrace files referred to Oracle .DLLs, and the lack of Progress error messages in the DataServer log file would suggest that the problem was caused by an Oracle bug.

FIX:

Upgrade to Oracle 10G R2 version 10.2.0.4.0