Kbase P132377: Can't access source DB after abnormal shut down.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  24/02/2010 |
|
Status: Verified
SYMPTOM(s):
Can't access source DB after abnormal shut down.
Replication agent stopped
When trying to access the DB shows error (10356).
Access to database <db> not allowed. The database is enabled for site replication but either replication is not running, or this process is not authorized to open a replication enabled database. (10356)
DB can't restart because of error (10545).
Connections to this database will not be allowed until all Database Services started have completed their startup and initialization. (10545)
Replication server cannot be terminated because of error (829).
** The file <name> is not the correct after-image file. (829)
After Imaging can't be disabled because of the error (10545).
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge Replication 10.x
Fathom Replication
CAUSE:
Current AI extent is corrupted, causing the replication commands to fail.
FIX:
Try to use your last backup or the target DB to restore the DB and roll forward the After Image extents. If this is not possible perform the following steps as a last resource.
1.- Make a backup of your current DB
2.- Truncate the BI
3.- Rename the .db of the source DB
4.- Rebuild the .db file using the command: prostrct builddb <db name>
5.- If access to the DB is still not possible due BI time stamp problems, truncate the BI adding the -F parameter.
6.- Access the DB in single user mode.
7.- Dump and load DB into a new structure.