Consultor Eletrônico



Kbase P132252: The ODBC Drivers are not detected by the ODBC Data Source on Windows 64 bit system
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   06/05/2009
Status: Unverified

FACT(s) (Environment):

OpenEdge 10.1x
Windows 64-bit
Windows 2003 x64

SYMPTOM(s):

ODBC Drivers are not being seen in the ODBC Data Source Administrator

SQL Client Access product is installed.

Complete installation validated in %DLC%\install\response.ini

No errors were detected during installation.

%DLC%\installd.ini shows all JDBC and ODBC client options are set to 1

HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI does not show the ODBC Driver for 10.1B

CAUSE:

When the 64-bit version of Windows is running, the Progress install properly registers all ODBC drivers - they are just in a different place on x64.
Instead of the registry keys being added under:

HKLM\SOFTWARE\ODBC\ODBCINST.INI
HKLM\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers,

The registry keys are located under:

HKLM\SOFTWARE\Wow6432Node\ODBC\ODBCINST.INI
HKLM\SOFTWARE\Wow6432Node\ODBC\ODBCINST.INI\ODBC Drivers

When configuring the ODBC drivers from the usual executable:

%SystemRoot%\system32\odbcad32.exe or %WINDIR%\System32\odbcad32.exe

These drivers cannot be found as they are created on the 32-bit side of the x64 system. There are currently no 64-bit drivers available for Progress on Windows 64-bit.

FIX:

A different DSN Administrator executable needs to be run in order to configure the 32-bit ODBC Drivers.

Create a desktop icon pointing to the following location:

%WINDIR%\SysWow64\odbcad32.exe

This will start the ODBC Data Source Administrator and from here, you will now be able to configure the drivers provided with the license installed.