Kbase P132154: Error 9460 with WebClient 9.1x after installing WebClient 10.x
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/16/2008 |
|
Status: Unverified
FACT(s) (Environment):
Windows
Progress 9.1x
OpenEdge 10.x
SYMPTOM(s):
Error 9460 with WebClient 9.1x after installing WebClient 10.x
Error during WebClient application startup
CODEBASE-LOCATOR attribute <attribute-name> is unavailable - WebClient could not properly set up or use the security cache (9460)
Issue happens after WebClient 10.x was installed and uninstalled
Issue persists after uninstalling and reinstalling WebClient 9.1x
Issue persists after uninstalling and reinstalling WebClient application
CAUSE:
Some components from the 10.x installation interfere with the initialization of the 9.1x application.
FIX:
Upgrade application to OpenEdge 10.x.
As a workaround, it is possible to remove all trace of the WebClient installation from the system and allow for a fresh installation of the 9.1x runtime. The following steps are recommended:
1. re-install WebClient 9.1x and 10.x.
2. use the Add/Remove programs from the Windows control panel to remove any installed WebClient application, then both versions of WebClient.
3. check if there are any files named "prox.dll" left in C:\Program Files\Common Files\Progress Software or subdirectories. If there are any, open a command prompt then use the command:
regsrv32 /u <full\path\to\prox.dll>
4. remove the directory C:\Program Files\Common Files\Progress Software and contents
5. using the Registry Editor, remove the following key/values:
HKEY_CLASSES_ROOT\.prowcapc
HKEY_CLASSES_ROOT\.prowcapp
HKEY_CLASSES_ROOT\Applications\prowcini.exe
HKEY_CLASSES_ROOT\CLSID\{82C84648-098E-11D4-937E-00C04F795241}
HKEY_CLASSES_ROOT\Interface\{85B4A627-7552-3AA6-8A1C-A213C5788FEC}
HKEY_CLASSES_ROOT\ProgressFileWCD*
HKEY_CLASSES_ROOT\ProgressFileWCP*
HKEY_CLASSES_ROOT\ProgressWebClientApp
HKEY_CLASSES_ROOT\TypeLib\{82C8463B-098E-11D4-937E-00C04F795241}
HKEY_CLASSES_ROOT\TypeLib\{78561600-AF48-11D4-81C4-00C04F6B9770}HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.prowcapc
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MenuOrder\Start Menu2\Programs\PSC WebClient*
HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\MUICache\
-> C:\Program Files\Common Files\Progress Software\*
-> C:\WebClient* (WC install directory)
HKEY_CURRENT_USER\Software\PSC\WebClient
HKEY_LOCAL_MACHINE\SOFTWARE\<AppVendor>\<AppName> (of any WebClient-based application)
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.prowcapc
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.prowcapp
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Applications\prowcini.exe
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{82C84648-098E-11D4-937E-00C04F795241}
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Interface\{85B4A627-7552-3AA6-8A1C-A213C5788FEC}
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ProgressFileWCD*
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ProgressFileWCP*
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ProgressWebClientApp
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\TypeLib\{82C8463B-098E-11D4-937E-00C04F795241}
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Code Store Database\Distribution Units
-> search for URL of setup.exe for WebClient, remove entries
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\Prowc.exe
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDlls\
-> C:\Program Files\Common Files\Progress Software\*
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\
-> search for WebClient, remove keys
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\<AppVendor> <AppName> (of any WebClient-based application)
HKEY_LOCAL_MACHINE\SOFTWARE\Progress Software\WebClient
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\WebClient
HKEY_LOCAL_MACHINE\SOFTWARE\WebClient
Replace "S-1-5-21-1171554181-3024118858-3057081927-1019" in the following by the corresponding ID on your system then remove the entries:
HKEY_USERS\S-1-5-21-1171554181-3024118858-3057081927-1019\Software\Local AppWizard-Generated Applications\WebClient Application Assembler
HKEY_USERS\S-1-5-21-1171554181-3024118858-3057081927-1019\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.prowcapc
HKEY_USERS\S-1-5-21-1171554181-3024118858-3057081927-1019\Software\Microsoft\Windows\CurrentVersion\Explorer\MenuOrder\Start Menu2\Programs\PSC WebClient*
HKEY_USERS\S-1-5-21-1171554181-3024118858-3057081927-1019\Software\Microsoft\.Windows\ShellNoRoam\MUICache
-> C:\Program Files\Common Files\Progress Software\*
-> C:\WebClient* (WC install directory)
HKEY_USERS\S-1-5-21-1171554181-3024118858-3057081927-1019\Software\PSC\WebClient
6. restart the system
7. install the WebClient 9.1x runtime again, using setup.exe from the install directory (not web).
This will ensure a fresh installation of WebClient. If the issue persists, contact Progress Technical Support..