Consultor Eletrônico



Kbase P132137: ubroker log files larger than logthreshold size
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   25/03/2009
Status: Verified

SYMPTOM(s):

ubroker log files larger than logthreshold

log file threshold size range is valid

-logthreshold between 500,000 and 2,147,483,647

srvrLogThreshold and srvrNumLogFiles are set

brkrLogThreshold and brkrNumLogFiles are set

resulting log files are correctly named:

asbroker1.server.000001.log
asbroker1.server.000002.log
asbroker1.server.000003.log

FACT(s) (Environment):

All Supported Operating Systems
OpenEdge 10.x

CAUSE:

The append option is set against the related ubroker logging:
Append to agent log file = true

FIX:

At the next opportunity when the ubroker in question is stopped:

1. archive current ubroker log files, so that the logfile directory is empty
2. consider increasing the number of log files or disabling the append toggle and perhaps increasing the threshold size. Ubroker log files quickly reach threshold size when logging entry types and higher logging levels are specified, eg: UBroker.All,DB.Connects,4GLTrace,FileID,QryInfo
3. If the logfile directory is not local to the ubroker (eg: a mapped drive accross the network) Network latency may also be affecting the content of each ubroker log file.
4. Consider tuning the srvrLogWatchDogInterval property (default 60 seconds)
5. Note that agents must be informed that the log file is switched; if they are busy we do not interrupt them. The next time they are available they will get the message to use to a different log file from the broker and then they will start writing to the new server log. It is expected that the server log size may vary somewhat because of this behavior.