Consultor Eletrônico



Kbase P132055: WebClient Application fails to run and generates error 4399 progress.cfg license has expired.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   03/06/2008
Status: Unverified

FACT(s) (Environment):

Windows
OpenEdge 10.x

SYMPTOM(s):

WebClient Application fails to run and generates error 4399 progress.cfg license has expired.

More than one installation of Progress / OpenEdge installed.

WebClient is installed on the local machine.

Non-WebClient Progress installation is installed on remote file system.

Environment variable for PROCFG point to remote file system.

WebClient works for some users but not every user.

CAUSE:

The remote file system the environment variable PROCFG is pointing to may not be available or permissions to the progress.cfg file may be insufficient to allow the read.

When the WebClient attempts to start it will look for the standard Progress / OpenEdge environment variables.
It will attempt to check the progress.cfg if PROCFG is set.

If there is no drive letter which corresponds to the PROCFG environment variable definition this will trigger a failure condition.

FIX:

Make sure references defined for the environment variable PROCFG are valid.
If the references is to a remote file system, make sure the remote file system is mounted / mapped.
Make sure the user has sufficient privilege to read the file.