Kbase P130840: Updates sent via Sonic are not getting to the database.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  23/04/2008 |
|
Status: Unverified
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge 10.x
SYMPTOM(s):
Updates sent via Sonic are not getting to the database.
Sonic messages are being queued up.
appservername.server.log shows error:Procedure end error (8397)
Checking ERROR-STATUS:NUM-MESSAGES for the error (8397) gives <name> table does not exist.
CHANGE:
Client created a multi-extent database by running prostrct create. They ran procopy %DLC%\empty4 dbname and then proceeded to startup the database and run their application.
CAUSE:
They missed a step in the process of creating the database. The step missed, was to procopy the empty database that contains the application schema.
FIX:
Procopy the application empty database that contains the needed schema to the current database.