Consultor Eletrônico



Kbase P130812: When clients exit from an application, prowin32.exe crashes with the memory could not be "read" mes
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   5/14/2008
Status: Unverified

FACT(s) (Environment):

Windows
OpenEdge 10.1A
OpenEdge Database Category: Configuration
OpenEdge 10.1A02 32-bit Service Pack

SYMPTOM(s):

When clients exit from an application, prowin32.exe will crash.

The instruction at "0X7c911e58" reference memory at "0xffffffff", the memory could not be "read".

Users encounter the problem approximately 20% of the time.

Application was recompiled.

Program libraries were rebuilt.

Twenty other sites are running fine with the same setup.

The crashes and lockups occur on two separate screens in the application

Screens for both windows contained a third party ActiveX control

Events were triggered by maximizing the window and then trying to restore it.

Re-registration of the 10.1A prox.dll file in the C:\Program Files\Common Files\Progress Software\10 directory had no effect.

CAUSE:

The exact cause is unknown at the time of this writing.

FIX:

In order to apply this fix .NET2.0 is required.
Rename the 10.1A prox.dll file in C:\Program Files\Common Files\Progress Software\10 directory and then copy in a 10.1C prox.dll. Register the 10.1C prox.dll file.