Consultor Eletrônico



Kbase P126094: _sqlsrv2 process goes runaway with 100% CPU / SQL clients fail to terminate
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   29/11/2010
Status: Verified

SYMPTOM(s):

ODBC Test connect fails to terminate session.


Cognos application fails to cancel a running SQL query

_sqlsrv2 process starts consuming more and more CPU

A protrace.<pid> file produced by sending the _sqlsrv2 process kill -16 signals shows that the process is spinning in a poll() call.

Client is able to connect to the database

Login usernum <num>, remote SQL client. (8873)

Usr set name to . (7129)

The 453 logout message is not written to the log file for the ODBC client

Logout by <user> on <ttyxxx>. (453)

Promon shows remote SQL client still logged in after the client has exited their session.

Proshut shows remote SQL client is still logged in even though the client has exited their session.

FACT(s) (Environment):

OpenEdge 10.1B03 64-bit Service Pack
OpenEdge 10.1B
OpenEdge 10.1B02 32-bit Service Pack
OpenEdge 10.1B03 32-bit Service Pack
OpenEdge 10.1B02 64-bit Service Pack
OpenEdge 10.1B03 64-bit Service Pack
Progress 9.1x
All Supported Operating Systems

CAUSE:

Bug #OE00159057

CAUSE:

An error code returned from the poll() call is not handled properly, so a process could potentially loop continuously calling poll() over and over.

FIX:

Upgrade to 10.1C or later.

If your site is unable to upgrade to 10.1C, upgrade to 10.1B03 and contact Progress Technical Support for additional assistance in obtaining the finalized fix for this issue.