Kbase P130534: Errors 778 and 735 are displayed in the WebSpeed Server log file due to connection timeout settings
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/04/2008 |
|
Status: Unverified
FACT(s) (Environment):
WebSpeed 3.1x
OpenEdge 10.x
All Supported Operating Systems
SYMPTOM(s):
Errors 778 and 735 are displayed in the WebSpeed Server log file due to connection timeout settings on the firewall
Firewall timeout causes WebSpeed agent to be disconnected after being idle for more then two hours
Errors 778 and 735 displayed within WS server logs
Error reading socket, ret=10054, errno=2. (778)
** Incomplete write when writing to the server. (735)
Error 8127 displayed within WS broker logs
ServerSocketsIPC <operation> IOException : <IOException_string> : <IOExceptionMsg_string> (8127)
ServerSocketsIPC read() IOException : java.net.SocketException: Connection reset by peer: JVM_recv in socket input stream read : Connection reset by peer: JVM_recv in socket input stream read (8127)
Web server and the WebSpeed Transaction Server reside on the same machine on DMZ
The agent log shows the agents are causing the errors are idle for more then two hours before getting 778 and 735 errors
The autoTrimTimeout for the WebSpeed broker is set to 6000 seconds
Database resides inside the firewall on a separate UNIX machine
The -minport and -maxport is not used to to start the database
Only first twenty Database server port range are opened through the firewall
CAUSE:
After more then two hours of idle time, firewall times out. This firewall timeout causes the WebSpeed agent to be disconnected from the database, hence, the errors 735 and 778 appears on the WebSpeed server log file
FIX:
There are two workarounds for this issue, and they are:
1. Disable firewall timeout
or,
2. change the broker's autoTrimTimeout setting to 1800 seconds, and change the minSrvrInstance to 0 (zero).