Consultor Eletrônico



Kbase P130391: OpenEdge application that uses the Crystal Reports runtime viewer control on windows has issue conne
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   6/30/2008
Status: Unverified

SYMPTOM(s):

OpenEdge application that uses the Crystal Reports runtime viewer control on windows fails to connect to Active Directory


The report for Active Directory runs fine in Crystal reports but not from the viewer in the application.


Application viewer successfully runs reports connected to progress, oracle, and SQL Server databases

The application is making connections to multiple data sources via the runtime viewer.


Same application runs fine if connecting to just Active Directory, one data source.

Report was designed in Crystal Reports 11.

The runtime control used was version 10, but the same issue results with the version 11 runtime control

FACT(s) (Environment):

OpenEdge 10.x
Related Non-Progress Products

CAUSE:

If a crystal report has more than one data source then it could have login problems when used in the viewer control.

FIX:

Change the EnableLogonPrompts property of the crystal reports control from true to false then the report will work in this case.