Kbase P130132: AppServer fails to start with Server exec error : error=123 (8109) in AppServer broker log file
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  4/3/2008 |
|
Status: Unverified
FACT(s) (Environment):
Progress 9.1x
OpenEdge 10.x
SYMPTOM(s):
The AppServer fails to start.
The AppServer.broker.log shows Server exec error : CreateProcess: c:\progress\bin\_proapsv.exe" -ubpid 1696 -Ms 1 -logname <AppServer name> -logfile "c:\tmp\<>.server.log" -logginglevel 3 -logentrytypes 0 -ASID 1 ubpropfile"C:\Progress\properties\ubroker.properties" -db c:\<pathe to db> -ld <dbname> -cpinternal UTF-8 -cpstream UTF-8 error=123 (8109)
ERROR: cannot start server. (8100)
Ending serverPool thread: S-0001. (8077)
admin error response received: 2. (8067)
Error 123: The filename, directory name, or volume label syntax is incorrect.
Progress Explorer shows @{Startup\DLC}\bin\_proapsv.exe" under Server Executable file property of the AppServer.
CHANGE:
Manually entered information for the specific AppServer configuration.
CAUSE:
In the ubroker.properties file the property srvrExecFile=c:\progress\bin\_proapsv.exe" in the AppServer Configuration has one " at the end of the entry but none at the beginning of the entry.
FIX:
Place a quote at the beginning of the entry as well:"c:\progress\bin\_proapsv.exe", as seen in the ubroker.properties file or do the same via Progress Explorer under the Server Executable file property of the AppServer:"@{Startup\DLC}\bin\_proapsv.exe".